Fullscreen view from TimeSpanPicker shows no LoopingSelectors

Apr 21, 2011 at 5:29 PM


I just added Coding4Fun.Phone.Controls.Toolkit.dll for TimeSpanPicker to my project without any customization. But when I tab on my device on the control to open the full screen mode I can't see any of the 3 LoopingSelectors. It is as the 3 LoopingSelectors are not added to the page. I can only see "CHOOSE DURATION" and the Done/Cancel buttons. It is the same when I open the TimespanPickerPage.xaml in Expression Blend. It is also empty. The fullscreen mode on my device looks exaclty the same as Expression Blend: title and buttons are visible but no LoopingSelectors.

Things I tried:

  • Directly downloaded the Coding4Fun.Phone.Controls.Toolkit.dll from Downloads page --> can't see any LoopingSelectors in full screen mode
  • Downloaded the complete source code and compiled the dll. Added that self compiled dll --> same effect, can't see LoopingSelectors
  • Added the Coding4Fun.Phone.Controls.Toolkit.csproj directly to my project --> same effect, can't see LoopingSelectors

I tried to debug the TimeSpanPicker, but I'm not sure where to look for this error.

As I understand, the TimespanPickerPage.xaml is navigated to when opening the full screen mode. It is also calling the InitDataSource from TimespanPickerPage without any errors. So why can't I see any of the LoopingSelectors?


Side note: I'm also using MVVM Light Toolkit, Telerik RadControls Toolkit and Silverlight for Windows Phone Toolkit Feb 2011 in my project. Maybe one of these Toolkit is interfering?


So can someone tell me where to begin to look for this bug? Or how can I fix this? I just need a simple Timespan picker in my project to let the user pick a duration.


Best regards,


Apr 21, 2011 at 6:42 PM

What build are you using of the tools?  in the Test diagnostic app with the 1.3.2 build, I can pull up a stock timespanpicker and it renders fine.  Can you provide a repo?

Apr 22, 2011 at 8:39 AM

sry, maybe I should've said that the sample project with TimespanPicker works fine. Therefore there must be a conflict in the Toolkits I'm using I think.


Can you point me to some places to set a breakpoint to see if TimespanPicker is indeed working fine?

Apr 22, 2011 at 1:14 PM
Edited Apr 22, 2011 at 2:53 PM

I finally found the error:

I'm using RadPhoneApplicationFrame instead of PhoneApplicationFrame. With PhoneApplicationFrame I can see all three LoopingSelectors.

So can someone tell me how I can fix this? Because I need to use RadPhoneApplicationFrame.


private void InitializePhoneApplication()
    if (phoneApplicationInitialized)

//RootFrame = new PhoneApplicationFrame(); RootFrame = new Telerik.Windows.Controls.RadPhoneApplicationFrame();



finally found a quick fix: When using RadPhoneApplicationFrame with transition the NavigationStopped event will be fired when navigating to PickerPageUri

--> HandleFrameNavigationStoppedOrFailed will be called and it will unhook the HandleFrameNavigated event handler

--> Max and IncrementStep will not be set

--> Primary/Secondary/TertiarySelector.DataSource are all empty

--> won't see any Selector in full screen mode


I just commented "_frame.NavigationStopped += HandleFrameNavigationStoppedOrFailed;" out in DateTimePickerBase.cs and it seems to work now with RadPhoneApplicationFrame.

Apr 23, 2011 at 1:53 AM

This really should be a bug, not a discussion.

Fixed in Completed: At revision: 65579 

I took a more defensive approach rather than commenting as the code is based on the SL toolkit.

Apr 26, 2011 at 8:32 AM

ok thanks.